• The friendly Linux forum for all users.
Dismiss Notice
Welcome to Linux Forum! As we have just launched, please help us grow by telling your friends about us and posting in the forum. Thanks!

Trouble setting up Linuxcnc (Debian)

Discussion in 'Linux General' started by Reminewbe, Mar 5, 2017.

  1. Reminewbe

    Reminewbe New Member

    Hi

    Looking for anyone to help switching to Linuxcnc from Mach3 to operate my cnc router. Have installed Linuxcnc and have tried to configure. The documentation from my tb6560 board (Chinese) requires pins 2, 6, 14 to be enabled. There is no "enabled" in the drop down menu for these pins--could it be the unused option? Also had a problem when trying to run the program--indicated a problem with limit/home switches. I didn't set them yet--only indicated their PIN numbers. Pin 13 for x,y, and z axis limits, pin 10 for x home/limit, 11 for y home/limit, and 12 for z home/limit as I did in Mach3.

    Any help greatly appreciated!

    Thanks
    Reminewbe
     
  2. Scotsgeek

    Scotsgeek Member

    We can help you with Debian Linux, which I use exclusively, but probably not Linuxcnc.

    Have you tried the forums on the Linuxcnc website? Someone there may have experienced the same problems, or something similar.

    Also, if not already, the Documentation on the site.

    Good luck!
     
    Crippled likes this.

Share This Page