• The friendly Linux forum for all users.
Dismiss Notice
Welcome to Linux Forum! As we have just launched, please help us grow by telling your friends about us and posting in the forum. Thanks!

No linux working properly for Alienware

Discussion in 'Linux Installation' started by James, Feb 27, 2017.

  1. James

    James New Member

    I am so pissed. I just got a seemingly amazing Alienware, and have tried distro after distro. None of them work!! They either install and won't boot up after, or just won't install! I just want to install Ubuntu. I tried it on another PC and it worked perfectly. When I did it on my new laptop, it installed but just loaded up a purple screen after a restart. It with every distro it shows missing firmware for my wireless card but I can still connect to the internet via ethernet or Wi-Fi. Why? My wireless card is some qualcom by the way.
     
  2. atanere

    atanere Active Member

    Hi James, and welcome to the forum.

    It's easy for Linux to have trouble with the latest-greatest, cutting-edge, top-shelf hardware... because OEM's like Dell/Alienware often do not provide Linux drivers for their hardware. Please blame them for that.

    But there is so much information that you failed to provide that it is impossible to tell if you might be able to use Linux on your laptop... or not. There are MANY considerations to replace or dual-boot with a Windows system. So, to start, you did not say if you want Ubuntu only, or if you want to dual boot.

    Assuming you have Windows 10, they usually employ a "feature" called hybrid boot that will put your laptop into hibernation instead of shutting down (if you choose shut down). So then, if you try to boot on Linux, you already start to encounter problems because Windows is actually still running in this hibernation mode. There are ways around this, but it could be the start of your problems.

    Further, since just before Windows 8, the computer firmware that used to be called BIOS has been replaced with a new firmware called UEFI. This creates many problems for Linux, but again, there are ways to deal with it once your realize that it is part of the problem. You need to get into the UEFI settings and usually make some changes. But, UEFI is a strange beast and different OEM's implement it differently... so some Linux distros work better than others, and some don't work at all with UEFI. Ubuntu is usually pretty good, but you still may need to make changes before it will install and boot.

    Then, if you get it installed and booting... you may be back to the issue of drivers.

    Installing operating systems is not a trivial task. You may need to put a lot of effort into making it work. Folks here will help you, but you need patience and to communicate better than your opening rant.

    If you want to continue, and if you want to keep Windows (or possibly restore it later), you should make a "recovery set" on DVD or USB. Dell/Alienware probably has an application to make the recovery set that will bring your laptop back to its factory-new condition. You should also back up any important files that are on your Windows system. Things can (and do!) go wrong when installing operating systems and you may get into a situation where it will not boot at all, and you may need the recovery set to get back to your current starting point. You do not want an expensive Alienware brick, right?

    So, what would you like to do?

    Cheers!
     
    Rob likes this.
  3. James

    James New Member

    Linux mint works. Just tried that. Now I just need to install the ath10k drivers or firmware. It says it's missing but my wireless card works. Should I bother?
     
    Rob and atanere like this.
  4. atanere

    atanere Active Member

    Mint is a great distro. Happy that you have already found success.

    About the wireless... "if it ain't broke, don't fix it!" :D

    Cheers!
     
  5. Crippled

    Crippled New Member

    If it works I wouldn't bother installing anything else.
     

Share This Page