• The friendly Linux forum for all users.
Dismiss Notice
Welcome to Linux Forum! As we have just launched, please help us grow by telling your friends about us and posting in the forum. Thanks!

Can't Connect to Wifi Cinnamon Serena 18.1

Discussion in 'Linux Networking' started by CandleWight, Jan 6, 2017.

  1. CandleWight

    CandleWight New Member

    I am completely new to Linux. I just installed the newest version of Linux Mint: Cinnamon Serena 18.1, to two laptops that were having issues. One is an old Toshiba Satellite L305, the other a newer HP Stream Netbook PC 13. They both seem to be working fine except that they cannot connect to wifi. I can view wifi connections, but after entering the password, they don't connect. I can't find many resources for the newest version, but I read that, because it's so new, it still has some bugs. Is this one of them?

    I appreciate any help!
     
  2. CandleWight

    CandleWight New Member

    I think my problem may be a bit different. wireless connections are visible, they just don't work. Haha.

    I tried using the boot usb to update the drivers, like the article outlined, but it says: Failed to download repository information. Check your Internet connection.

    My Toshiba also just crashed and asked if I was running in fallback mode. Restarting it now.

    Edit: Don't know how, but my Toshiba's wifi is working after the crash! Still no progress on the HP.

    Maybe I should add, the HP has no LAN plug or wired option, while my Toshiba did. The HP's default was always wireless. After the Toshiba restarted, the default changed from wired to wireless. That's the only difference I've found.
     
    Last edited: Jan 7, 2017
  3. slu

    slu New Member

    HP has a terrible fetish that way. I have an HP 6600 printer that has no ethernet...just wireless. I will never do that again! HP was never the same after Carly.

    You should be able to discover the manufacturer and part number of the HP wireless chip from the terminal command lsusb. If you drill down through the text, it should show up. You may need to install a driver for that chip set in order to get it going. Definitely check on the linux mint forum https://forums.linuxmint.org for the best way to get this driver loaded and working.

    For you, I would strongly suggest getting a USB wifi dongle like the Edimax or better (signal) Panda PAU06. Both are available and cheap on Amazon and plug into a USB port on the HP. The drivers for those dongles are already present in the linux kernel so they should start right up. Mint should find them right away. They will probably show right up as wlan1 (on board HP wifi will be wlan0). USB-ethernet dongles are also available cheaply and ethernet is ALWAYS faster and more reliable than wifi.
     
  4. Rob

    Rob Administrator Staff Member

Share This Page